Workflow commons - Unable to start onboarding process

Hi All, I am on page  Mendix Academy - 6.1.1 Triggering the Workflow for the workflow training and receiving the following error for my button I've tried adding all kinds of data grids both inside and outside the EmployeeOnboarding entity, but nothing seems to be working.      
4 answers

HI Byron,


Are you following the learning path in Mx version 9.9.0?

Because there are some changes in the workflow commons module.

The system.WorkflowContext isn’t availble in the updated module. (below is a part of the learning path)


You can find all new information on the workflow update in this document below.



Hi Byron,

It seems like you don’t have the workflow available here to pass to the microflow you are calling.

You should place the contents of the page in a dataview with the entity workflowattachment as data source.

Hope this helps.



Unfortunately I cannot add a comment to your reply and insert an image. I think I've applied what you have identified, but its still not working, so i guess I didn't do this right.

No more errors, but what I'm unable to see now is the employees I have added on this page. It always shows as empty.

EmployeeOnboarding = ListView (Using a datagrid I don't get the option to add the entity employeeonboarding)




Final domain model in response to answer provided by Stijn.