Rapid Developers Course

When I select List View and add an Entity to my page all the List Item entries associated with the page go away. How can I prevent this from happening?    See Attached Screens,        
2 answers

Hey John,


I believe that you didn't select ‘automatically fill the content’ option while adding a list view; so at first, yes there would be nothing. However, you can add attributes through adding a text (and choosing the parameter inside the text- double click to see this)


You can use different tools to add different kind of attributes. Do not forget to add {1} in the text part. See the picture as an example.





hii John Marzo,

you only configure entity with you listview but columns are not mapped so data is not retreiving 

firstly remove the entity and again select the entity and when system ask you for automatically fill the listview content click on yes.

so all columns of the list view will be fetched by default 


you can also manually map the attribute ,

just place a text into listview and follow steps below in image 


  • firstly place the text into listview delete all caption and place a prameter place 
  • {1}  now click on the edit that is right side of the caption 
  • now click on the new under parameters section
  • now select the attribute path click on select and select one attribute that data you want to show on the page


repeat above for four steps for another attributes.


example image


you can choose only one attribute in one parameter 

so place multiple text into list for multiple attribute


if you are using mendix studio ,web modeler(web modeler  = software on browser ) then after place {1} in caption you will see add option below by clicking on it you can select the attribute of entity from there.

hope this will help you.