Problem with creating an user as MxAdmin

Hello, Logged in as MxAdmin in our application and tried to create an user. Got an error popup while saving the user.  We migrated our application  to 7.23.15 Mendix version recently. The above mentioned issue is only happening in this revision. Creating user in lower version(7.23.3) of our application works fine with same security settings. Not sure whats wrong. Did anyone faced this issue?   Log: 2020-09-09 00:23:15.057 ERROR - Connector: An error has occurred while handling the request. [User 'MxAdmin' with session id '80470dd3-XXXX-XXXX-XXXX-XXXXXXXX8a8a' and roles 'Administrator'] 2020-09-09 00:23:15.057 ERROR - Connector: com.mendix.webui.WebUIException: Applying change for 'Name' of object with id '105271641289785345' (Administration.Account) failed for security reasons. No read access for changed member. at com.mendix.webui.requesthandling.helpers.StateHandling.$anonfun$addChangesToState$4(StateHandling.scala:66)  
2 answers

Hi Mythili,

I faced similar issue sometime ago, this is to do with access rules on Account entity. Security is more strict in 7.23.3 so make sure you have correct access rules configured on account entity for Administrator role. Also, make sure in project security, you have administrator module role selected for system module and administrator can manage all other user roles as shown in the screenshot below.


Hope this helps! 


Hi Mythili,

I had the same issue. Your problem is caused by the fact that you probably did not select the last role in the list of selectable user roles: ‘(No user roles)’


When using selected roles, you need to select ‘No user roles’ to be able to create new users.

This solved my issue!