List view - build app from scratch - why can i only edit first row? (With screenshot)

Hello, I am a German student and new to Mendix. My task is to create a list with different groceries (first column) and their prices (second column). I tried to make an app from scratch, and i created a new page and chose list. However, only the first row is editable. But i want each row a different food. Please help me. I use “ Edit in Studio” only.
2 answers

Studio is the development of the app, but not the running app it self.

So in Studio you add a list, connects it with an entity (database table) define the attributes of the entity you want to show in the list.

In your case you want to show a list of Groceries. Thus you need an entity Grocery, with attributes like name, price, unit?

In the listview you set the entity Grocery as data source, in the list you connect the text widgets with the attribute name, price and unit. 

In the running app you will see in the first row the first record(object), the second row the second etc.

In development (Studio) you only see the connected attributes  


Suggestion; take the rapid developer learning path to understand more of pages, entities, domain model etc


This is how it turned out. Now it works. :)