Notification Module not working when in Cloud

I have used the push notifications module version 3.0 which has been updated for Mendix 6.0 When I run it locally the messages get sent without a problem. However on our cloud node, we get a java error: APN: Message to <0b9ea091 d84e7daa dd6317d3 0c160fe1 2ee5a4f7 76dfb1eb 63dead22 6bca8614> failed: java.lang.RuntimeException: Invalid hex character: < We use the exact same settings on the cloud as locally. The registration adres is the same and the APN service has the same certificate. The registration Id with the "<" is generated from somewhere deep in the module. Since the same input is used locally as in the cloud a invalid hex character error is very confusing. Any idears on what the real problem is would be very welcome. What I have already tried: Various ways of writing the registration adres Restarting the APN service Recreating the APN service Checked that locally we run with emulate cloud settings
1 answers

I have found out what the problem was.

We were generating the app that recieves the notifications directly from Xcode. The provisioning profile that was used for the app only worked for my collegue, but not for my own device. Since I was testing it the second time from the cloud, I presumed that the difference layed in the environment.

My advice is that when busy with the notification logic and it does not work is to start from fresh with the whole certificate process of apple.