Studio Pro 9.?.?,9.16.0,9.17.0/Make It Native 9-Multiple functions failing in the last few weeks that had NO code changes

  2022-09-09 16:14 CDT So incredibly (insert multiple words that are so vulgar they cannot be said here). Spent an entire MONTH trying to figure out why:  -RED SCREEN OF DEATH ON CLIENT grumbling about MEMORY when host and client storage space did not change, in fact was increased using special cleanup tools  (Disk Cleanup/CCleaner/etc) -a SECONDARY RequestLocationPermission/GetCurrentLocation goes into an infinite loop during the GetCurrentLocation phase NOTHING had been changed in app. How often do companies have a NATIVE unplanned production outage because of some kind of code change outside the app and how long does it take to be up again to be a high availability system/app? Tried EVERYTHING -Upgrade Studio Pro through multiple versions -Reinstall Make It Native 9 hoping for an upgrade fix -Redownload Native required Mendix Marketplace modules (CommunityCommons,NanoflowCommons,NativeMobileResources-08/31/2022 versions) -Update Widgets/Download Additional Widget Warnings -Fix issue with Mendix modules that have domain entity attributes using the word "string"  (which has to be redone ever time module is updated-pain in the .......-design failure) -Search for some kind of log on host for days (non found) -Upgraded Android 12 Patches (that do not automatically happen, you have to download them from the Play Store-who knew?) -Didled around for a week trying to learn how to use Android SDK to get a log (OEM cable issue) -Log finally produced that after transfering to host took forever to open to work on because of its size -Weeded through THOUSANDS of lines of log from every event under the sun which revealed nothing using specific/relative search words -Added "Show Message" with attemts counter to determine if functions complete but do not work -some other things that can't even remember because so much time has gone by and so many resolutions tried -attempted to jump of a bridge  -ask a friend if they had a double barrel 20 gauge (come on, laugh or one is going to cry) The prereqs/coreqs/dependencies are absolutely (insert words). How would one like a month stolen out of their life when every minute is precious. Most people don't understand their mortality until either they lose both parents, lose a child, or lose a mate. This one has 2 of the 3. Literally work on an app from the moment awakening until sleeping after an hour of haha Tele to calm thyself. Then during sleeping, literally dream about the current problem that can't be resolved "yet"-it is like having a nightmare about a tornado where there is no where to run. Had just finished proof of concept after 2 years and 1 month then within the next week everything had to break down AGAIN to go fooee another time, because of one little change made somewhere by some entity that broke one of five primary necessary SIMPLE functions. Fix this/Break that Call it a rant if you like, doesn't one have the right when QA is not even on a scale of 1 to 10?  In the words of another “Software can be cruel”.  This cruel? So in return for what many will call a rant, I will give the answers to this issue for the next poor sap that encounters this so they don't have to waste time if they find this: Cause: Unknown code Change by unknown entity Resolutions: -Reduce a table size (AGAIN) to stop red screen of death from happening.  It is still unclear why the client should be trying to hold all the data for a table upon load.  Is is still unclear why the client is not retrieving data from the host when required and optimized. -Now here's the kicker after deducing everything to the Nth degree: In order to get the SECOND Request Location Permission / Get Current Location from locking up a 3000ms wait had to be inserted between them, which is the furthest thing from what would think would solve the problem. Tim, if you happen to read this, add something so it can be marked answered and you can get an extra point. (Feels like a pinball machine and your the top guy, and should be-lol) ----- 2022-08-31 16:48 CDT Upgrade from 9.16.0 to 9.17.0 has not resolved Make It Native Collapsing irregularly with no host/client errors.  And something may also be going on during a second get current location (always with permission function beforehand).  It is unclear what is causing the failure. (Bug/Hardware/Android Level/etc.)  I’ve tried to get developer logs using Android Development mode but the email sent only has a screen shot-no text attachment to xref a log timestamp.  I was hoping the language in the update talking about memory leaks would fix this, but did not.  So hoped a version update would have fixed things so still at a lost. --------- 2022-08-26 14:39 CDT So after google searching myself to death I finally found this: 7 days ago (about the time of my new mx failures) "I want to get the current location for android with out using Google APIs Key that's why I'm Using the Geocoder. it is working absolutely for many devices  but it is NOT for SOME selected devices like Latest ***android VERSION 12*** and in OnePlus_v10,11,12." (I do have an API key and am on V12 for the record) So not only Native has 3rd party software dependencies, it is realized there are external hardware and their operating system dependencies. It would be very difficult if not impossible for mx to find this situation even with daily automated testing as suggested previously. So who should be getting on you know who's (insert word) to get this fixed and has the contacts to do so? It is definately not me-above my connections to get to Boogle that thinks they can automate everything without human support. This just reinforces that dependencies WILL make a production environment fail at any time and a developed Native Mobile app cannot be high availability. Very  ?can’ t even find the words? that two years of work should have never started under these now known errors and ommissions. Hopefully I have an old device not upgraded to V12, with my luck probably not as I keep everything current (especially when it appears required). I am about ready to walk down to the cemetery and blow my head off being more tired and tired and tired of fighting, having no hope of finding a job in my industry that dramatically changed and 3 steps from being homeless which when I started this was suppose to be the reason to help others.   Running out of the energy to fight in general with this screwed up world. "If you never, ever, had to worry about a bill again for you and your immediate family, meaning a roof over your head, food on the table, clothes on your back, and the other necessities,  but in exchange you would have to do something that makes a difference in the world. What would you do?"  I’ve asked this question to over 5,000 people in the last 5 years.  I know the top 3 and some that blew my doors off and some that said I don’t know and some few said I’m already doing it.   2022-08-26 13:33 CDT I don’t know if it happened in a dream because I literally dream about what I’m working on because there is nothing more important to me.  So rising this a.m. it occured to me, “Oh, I forgot that I use get currently location heavily auditing user entries, exits, (for user safety) and when needed for classified functions.”  Sometimes the function works and most of the time fails NOW (not before) even if changes are made to avoid skipping time outs.  Don’t know if anyone will have an answer to this and pretty sure I’m on my own.  Perhaps if I google my self to death I can find some external reasoning for this as I’ve searched the forum to death to see if anyone else is reporting this issue which may be causing the new intermittent complete colapse of run time without and ANY errors, messages, clues.  Trying to recall function if timeout (even when increased to a rediculous point) often is turning into an infinite loop proving this is a major problem.   2022-08-25 05:51 CDT What am I to do?  Another up all morning trying to figure out what’s broken, who broke it, and why to the point I can’t see straight and frustrated and so exhausted I have to finally have to go to bed and pray when I awake things got fixed and it will be a better “NATIVE” day. I’ve spent 3 days with MULTIPLE failures occuring with MULTIPLE functions that were working just fine and with NO logic or version changes. Including load execution. For example, since there are no host lowest level console or client device error(s)  I finally resorted to using progress status on Nanoflow Commons for one topic failing “Get Location Permissions” and “Get Current Location” (that the later was mucked with in previous version of Nanoflow Commons per github version notes and google has notated new deprecations coming with Geocaching if that is where the function leads to, also “High Accuracy” parm always failed since day 1).  There is no permission issue but the get location (on Android Samsung Galaxy S10 Android 10) will not work on top of the intermittent failures at any point i.e. loading, 2nd Native Page, First Menu Selection, Animation Completion/Locking, Location Retrieval fails to retrieve relative data,  and the list goes on and on.  Location processing was one of six requirements for proof of concept, so now proof of concept that was just completed is no longer complete and build out is now halted until who knows when. Even reverting to previous versions did not resolve anything, that speaks for itself from a diagnostics point of view. I can’t get support using “Try It For Free”, which if mx was smart would do so bugs can be shaken out immediately to improve the product for the company’s and customer’s benefit. I swear I must be the only one putting “Native” through the ringer washer again and again and the stain even with bleach will not come out. (and haven’t even got to unit testing on an iOS that will have to rely on others to complete that portion of Native unit testing) I can’t rant in fear of being restricted from the forum. How long will I have to sit around this time for who knows how long meanwhile with my ….. in my …. praying for a miracle for fixes to happen? Why am I not working for mx QA?  There would be some serious house cleaning and business process improvements made. I wouldn’t rant, I would just state in a mx conference room with leads “I’m irritated” with reasons to disapprove of current SDLC performance as smoke is coming out of my ears so I don’t say what one would really like to say. If there are so many 3rd, 4th, 5th, and on and on dependencies then why is automated test scripts not run daily to detect external changes causing breakdowns immediately so a Level 1 team can confirm and communicate to customer and fix failures detected ASAP? If your a Global 500 and your production system(s) go down because of dependencies you know how the CIO is going to react.  Just like the day Microsoft security went down for a day which cost all of them so heavily reliant on a dependency when prereqs and coreqs are always implemented. “Ok folks, go home, senior I.T. staff will notify you when our dependency is back up and running.” I love this product, it’s the closest to the real deal of the 5 major proof of concept requirements that are common in any Global 500.   2:08 PM Friday, August 26, 2022 (GMT+2) Time in Netherlands.  It is wondered if I had support, does the mx staff work no matter what, when needed, night or day weekdays and/or weekend, to make things right,   2022-08-25 13:28 CDT Ran app 3 times in a row and zoom out animation locks at end near final completion of action and app closes.  4th time worked. “Get Location” processing worked on 5th time then stopped working 6-10+ reexecutions. ALSO, deletion of an image takes too long to complete and then failes and again here came the red screen of death. At this point app doesn’t just close for no reason when certain loads have irregular closures at various logic points. This is not a local host/client resource issue-This has to be something on the Mendix Servers side because logic was working fine until recently.  I believe something on Mendix sesrver(s) needs an emergency backout from some update that fixed something and broke a pile of other things. Through the last 2 hours of regression testing Make It Native did not show the red screen of death.   2022-08-25 10:10 CDT Todays new goody while attempting to “Get Location” and use information to retrieve data through Nanoflow.  What is going on with all the recent failures occuring with no changes?  Am I losing my mind?  Everything was working fine now everything is kaput for unknown reasons-someone 99.9% must have changed something.  If there is some weird bug in SP being reported or change in some server processing then we to know this.  Problems with need to be fixed asap or atleast notify all users and/or notify to revert versions.   System.Threading.Tasks.TaskCanceledException: A task was canceled.    at System.Windows.Threading.DispatcherOperation.Wait(TimeSpan timeout)    at System.Windows.Threading.Dispatcher.InvokeImpl(DispatcherOperation operation, CancellationToken cancellationToken, TimeSpan timeout)    at System.Windows.Threading.Dispatcher.Invoke(Action callback, DispatcherPriority priority, CancellationToken cancellationToken, TimeSpan timeout)    at System.Windows.Threading.Dispatcher.Invoke(Action callback)    at Mendix.Modeler.Debugger.View.DebuggerUI.ControllerOnBreakpointHit(PausedMicroflow pausedMicroflow) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Debugger\View\DebuggerUI.cs:line 306    at Mendix.Modeler.Debugger.Runtime.DebuggerController.ClientOnDebugEventReceived(IDebugEvent debugEvent) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Debugger\Runtime\DebuggerController.cs:line 160    at Mendix.Modeler.Debugger.Runtime.DebuggerController.StartDebugging(String url, SecureString password, ConnectionMode mode, IEnumerable`1 breakpoints) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Debugger\Runtime\DebuggerController.cs:line 92    at Mendix.Modeler.Debugger.View.DebuggerUI.<>c__DisplayClass52_0.<StartDebugging>b__1() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Debugger\View\DebuggerUI.cs:line 269    at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 29    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument) all systems operational Effort expended: ½ day (6 hours)
0 answers