Why SCSS is not saved after compilation?

I write SCSS styles. When I run the project locally, the styles don't work. But if I open any SCSS document and save it, all styles start working. After restarting the project, all styles stop working again.   And when colleagues receive my code, all styles again don't work until they open and save any SCSS document.   What could be the reason and how to fix it?
2 answers

Hi Maxim,


late comment, but just had the same issue. Clearing my cache solved the issue.

The scss/css files are cached in browser, whenever saving a document you directly inject the new value. But this doesn’t seem to apply when restarting the modeler/deploying, clearing the cache will force this.


I could remember there were a few versions of early Mx9 where this bug appeared. Would recommend upgrading the 9.6.0 To at least a newer version of 9.6.x.


Also make sure to upgrade the Atlas_core, data widgets, and atlas_web_content to the latest version. This is quite often overlooked.


double-check the theme (folder) → web → settings.json contains:

    "cssFiles": ["theme.compiled.css"]

as this is mandatory to compile the theme