Error with EncryptionKey for the Email Connector

I am using Mendix Studio Pro version 9.21.0 and imported Email Connector. I tried to configure it and provide my gmail as the email address in ‘Add email account’ step in the wizard.  Then I received in the console the warning: ‘The string provided is not an encrypted string. Returning the plain string.’   And a modal with error: Username and Password not accepted. Learn more at 535 5.7.8 y15-20020a17090629cf00b008caaae1f1e1sm2344001eje.110 - gsmtp Could you please help me to configure it. I provided 32 characters (only letters) for the dafault value in the EncryptionKey. I turn off my two-factor authentication in my gmail account.
1 answers



It seems that the error you're encountering is related to the authentication process with Gmail. Here are some suggestions that could help you resolve the issue:

  1. Make sure that you have enabled "Allow less secure apps" in your Gmail account settings. Go to your Gmail account settings, click on the "Security" tab, and scroll down to "Less secure app access". Toggle it on.

  2. Verify that the email address and password you are providing in the Email Connector are correct. Double-check for any typos or errors in the provided credentials.

  3. Ensure that the EncryptionKey value you are using is correct and consistent. The key should be 32 characters long, and you should use the same key in both the Email Connector and the Mendix application.

  4. Try to use an app password instead of your regular Gmail password. An app password is a unique password that you can generate in your Google account settings for apps that don't support two-factor authentication. To generate an app password, go to your Google account settings, click on the "Security" tab, and scroll down to "App passwords". Generate a new app password for Mendix Studio Pro and use it in the Email Connector.

If none of the above suggestions solve the issue, you could also try to use a different email provider or contact Mendix support for further assistance.