Mendix 10 problem: repository path my_path is not owned by current user

1
Hi! I decided to try out Mendix 10 in a small demo project and my friend and I created a project for this version. A colleague created the foundations of the project, made a commit to the Developer Portal and then added me as a Business Engineer. After downloading the project, it turned out that I don't have git permissions to this repository. In short: ’LibGit2Sharp.LibGit2SharpException: repository path 'C:/Repositories/Mendix/dummy-app-7-main_2/.git/' is not owned by current user’ The full text of the error is a bit longer… Unfortunately, I get the same error when I create a project myself and try to download it. I also have a similar error when I create a project locally and upload it to the server. After deleting the local copy, I can't download and use it because I don't have permission. It's some issue with the git repository and how to log in, but I haven't found a solution.
asked
2 answers
5

This is what I found and solved my problem

c# - LibGit2Sharp Exception: repository path not owned by current user - Stack Overflow

 

The origin for this "error" is a safety check that was added in Git to address CVE 2022-24765.

Therefore, one needs to put working trees that are on a path not owned by the current user on a safe.directory list.

There seems, however, be an inconsistency between vanilla Git and libgit2 regarding the handling of trailing slashes. For libgit2 to recognize a path correctly as safe, it must not end with a slash.

As a last resort, one can also add the * exception which completely disables this security check - only do this if you trust all users on your machine

 

Go to your gitconfig file

:C:\Program Files\git\etc\gitconfig file (if git is installed)

or C:\ProgramData\Git\config (if git is not installed)

 

add the following:

[safe]
    directory = *

answered
1

very valid option also for when using parallels on a mac, then you might also face this issue due to the C, Y and emulation drive!

answered