Rendering Thai characters

I am developing a Thai application in Windows environment, everything seems to be very smooth until I deploy it on Sun Solaris 10 connect with MySQL DB on Sun M5000 with 8xquad-core and 32GB Ram. It runs very very smooth except that the Thai character can not be rendered correctly on the web browser. I see "?????" instead of "สวัสดี" or Hello in Thai Here are things that I have already tried and it's not helping: Change encoding type in my database to UTF8 and TIS620_thai (I can insert Thai character directly via SQL, but cannot via Mendix platform. But if the table already contains the Thai text in the row, than Mendix is able to show and render the correct Thai character in the browser Every possible parameters in the Solaris environment that can be set to UTF-8 e.g. locale parameters Add parameter -Dfile.encoding=UTF-8 parameter before start Mendix platform Last hope: change character uncoding in my browser The last thing that I am suspecting, is the Jetty server, which I cannot see the configuration yet. Can anyone help me out with this problem? Thank you very much, Panayu
4 answers

Encoding problems almost always stem from having one of the encoding settings not explicitly set to UTF-8. The fact that everything works on your Windows servers means that it isn't a configuration problem in the Mendix Runtime.

You have already looked at a lot of settings, however, this thread describes a somewhat similar problem which was solved by setting a MySQL setting. A full description of how to set UTF-8 for MySQL and what different settings need to be take care of is described here.

I hope this will help you!


Thanks guys, but the problems are solved! Mendix is alive again on Solaris :) I have tested my run-time in windows which is connected with the MySQL running on the Solaris. As result, the weird "????" is still occur. So this is a confirmation that the problem is not caused by Mendix platform. So I check all MySQL settings again. And I found a mistake, which is caused by Sun engineer. There was a very small wrong configuration in the /etc/mysql/my.cnf. This is a very straight forward settings:

character-set-server = utf8

I still skeptic about the Sun engineer that he only set the encoding on the created DB, but not the whole MySQL engine by default. Anyway no time to figure it out yet why it's not working that theoretically should be working.

Thank you for all your help


I wouldn't know how to solve this but it seems you are not the only one experiencing this problem,

here's a link to a post on the MySQL-forum related to this specific problem:MySQL Forum, I hope you will find the answer you need there.


@Michiel, Thank you for your reply, but this topic is already closed. Believe this is more the issue with the encoding type in the database. It's the first thing Thai developer do when we create a database :)

So shall it be the problem with database?, Mendix in Solaris 10?, or the MySQL connector? or other infrastructure?