MXbuild issue

MXbuild tool is failing to build the project(mda) with the following error. ERROR: System.UnauthorizedAccessException: Access to the path 'C:\mendix\Registration-main\java' is denied. As the tool is based on .Net, I tried to fix the issue with no luck using the following methods suggested on various forums. Adding ‘Network Service’/’ASP.Net’ security groups and permissions on java folder Can anybody guide me to resolve the issue.
4 answers

Hello Ramesh,

I suspect you did not specify the '--java-exe-path' command line option to MxBuild. This option should point to the java executable that is installed on your machine. For example: --java-exe-path=C:\Program Files\Java\jdk1.8.0_40\bin\java.exe.

Note that this may not be the only option that you must specify. You will probably also need the '--java-home' option. Please execute "mxbuild.exe --help" to get a list of all available options.

Hope this helps,

Joeri Hendriks


If you have no changes locally, I would delete my local project, download it again and try again to build.

If you have changes you can try the following:

  • Change the location of your project, for example to C:\mendix\zzRegistration-main.
  • Download the project again from the teamserver to C:\mendix\Registration-main.
  • Copy the .mpr file from C:\mendix\zzRegistration-main\Registration.mpr to C:\mendix\Registration-main\Registration.mpr (the .mpr file contains all the changes)
  • Open the project in C:\mendix\Registration-main\ and try to build again.

At first glance, it sounds like whatever user is executing mxbuild.exe does not have access to the path you listed.

So, how are you running the executable? You may need to edit permissions on your C:\mendix folder (and sub-directories). Just right-click on the folder, select properties, and then take a look at the security tab.

Finally, do you actually have a folder called java in your project folder?


It worked. Thanks all.