Document generation - Timeout while waiting for document content

Update: After some more testing, we found out that the issue is caused by us adding a certificate to the access restriction profile for the root url of the application. We did set an exception for the /docgen/ path, which worked before when we only used an IP whitelist to distribute access to the application. Mendix support informed me the combination of certificates and document generation is currently indeed not supported.   Hiya,   I'm encountering an error when generating a document using the Mendix Document Generation module. For a while now, we've been developing a document that users need to be able to generate. This was working fine, until it suddenly stopped working on our acceptance environment. Locally it still works (and we don't have a functioning production environment yet), but on acceptance the microflow that is called from the 'Generate PDF from page' won't start. The log shows the following: TRACE - DocumentGeneration: Wait using backoff: 5000ms TRACE - DocumentGeneration: Document content has not appeared, stopping polling ERROR - Connector: An error has occurred while handling the request. Caused by: com.mendix.modules.microflowengine.MicroflowException: com.mendix.systemwideinterfaces.MendixRuntimeException: java.lang.RuntimeException: Timeout while waiting for document content; no content was received I've checked for security issues, revoked and recreated the environment's app registration, checked our Path Based Access Restrictions, none of this helped. Any ideas on what else we might try?   Thanks in advance!   Daan
2 answers

Hi Daan,

Could you check if any of the reasons that are mentioned in the module documentation for timeout errors could be applicable? If you verified those and the issue still occurs, please create a ticket with Mendix support via

Hope this helps!


Did you update the module to the latest version? Maybe this would solve your problem.


I had some issues as well, but this was solved by using the new PAT (Personal Access Token) instead of the API key's you had to use before.