Unable to update or open application after commit through Model SDK

Hi, I'm facing a very problematic issue with the Mendix Model SDK (4.83.0). I'm creating and committing a new Module to a test application (8.18.28) with the code below. The issue prevents apps from being updated or opened after a commit is made to the SDK.   async createModule() { // Configure client, parse parameters const client = new MendixPlatformClient(); const app = client.getApp(appId); const workingCopy = app.getOnlineWorkingCopy(workingCopyId); const model = await workingCopy.openModel(); const iProjects = model.allProjects(); projects.Module.createIn(iProjects[0]); await model.flushChanges(); await workingCopy.commitToRepository(); }   After this code runs, I'm able to see that a commit is made by clicking on the History button in the modeler. However, when I attempt to update from the modeler I receive the error below.   Mendix.Modeler.Utility.Progress.ProgressException ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentNullException: Value cannot be null. Parameter name: value   I've tried cleaning my project directory, which didn't work. I've also tried closing the modeler, deleting the app from my local and redownloading it, but that just results in a general error message from within the modeler when I attempt to download the app.   I've also tried running this code for a Mendix 9 application and receive the same error.
1 answers

It seems to me that the new module doesn't ever get a name. This example of creating an entity sets the name of that entity after creating it. I expect you need to do the same with a module.