Error when try to add Consumed OData Service

Hello: I am trying to consume an OData service that I have published. It has username and password authentication. When adding the OData service to the studio pro, it does not ask me for a username and password and therefore it cannot connect and gives me the following error. Server error No Authentication realm present. If i try to  access OData from a browser, it asks me for the username and I access it correctly.
2 answers

This should work: when entering the metadata URL (ending on $metadata), you should get a pop-up to provide the credentials.

Maybe it's a bug in Mendix 10.6.1 > You could try to upgrade to the latest MTS version (10.6.8)

Maybe you did have an error in the URL? It should give something like this in the browser:


This XML file does not appear to have any style information associated with it. The document tree is shown below.

<edmx:Edmx xmlns:edmx="" xmlns:mx="" Version="1.0">


Good luck!


That's the problem, I can't get it to show any pop-up. I have tried it in version 10.8.1 and 10.9.0 with the same result.


The web address is fine because if I put it in a browser I get a pop-up asking for username and password.