Spell check

Firefox, by default, enables spell check on textboxes of one or more lines (text area): http://support.mozilla.com/en-US/kb/Using%20the%20spell%20checker It turns out it even puts those nice red waves in text area's that are marked as read-only (editable: never) in the forms design. So our customers see them in Dutch text with some English words in it, like Cosmopolitan and Fun Fearless Female in "Wil jij het beste uit jezelf halen? Cosmopolitan helpt je daarbij, want Cosmo gaat over jou; je liefdes, je werk, je mode, je reizen en meer! Cosmopolitan adviseert, inspireert en is jouw TomTom in lifestyle-land! Ben jij een Fun Fearless Female? Neem dan nu een abonnement op het populairste tijdschrift wereldwijd!" That's rather annoying! I can't correct it via styling. There's no CSS option to mark something as readonly. It seems it can only be done in Javascript, but that can't be used in Mendix pages. Firebug shows the field as a textarea with the following attributes class="mendixFormViewtextarea" OverFlowHidden MxClientformDisabled" isinactive="true" readonly="" attr_read="true" and in the DOM-tab of Firebug it shows that spellcheck=true! Is it possible for me to change this behaviour? Or is this a bug that can only be fixed in a future version of Mendix? Have a look yourself at www.allesmag.nl, point to TIJDSCHRIFTEN in the header and choose Cosmopolitan from category Vrouw.
1 answers

You can use the rich text viewer, and set the 'plain text' attribute to true to achieve the desired effect.