Blank page after login

I'm getting a black page after logging in with both admin and normal user on multiple browsers (Firefox, Safari, MS Edge) The login correctly details are displayed but when I login as admin or normal user a completely blank screen is displayed instead of the home page (no menu, no default company icon from the template, not even static text from the home page referenced in the navigation is shown) If have tried making both a home page and showHomePage microflow the default home and have placed a debug on the showHomePage micro flow and can confirm it is invoked. I have tried role based home pages and no role based home pages. When I login the logs show a "Login OK" message from the WebUI log node. The user rights are correct as far as I can tell. Any ideas on this source of my problem are welcome. Below is the source of what actually loads <!doctype html> <html> <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> <title>Mendix</title> <meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1, maximum-scale=1"> <link rel="stylesheet" href="lib/bootstrap/css/bootstrap.min.css?635995334056127744"> <link rel="stylesheet" href="mxclientsystem/mxui/ui/mxui.css?635995334056127744"> <link rel="stylesheet" href="css/theme.css?635995334056127744"> </head> <body dir="ltr"> <div id="content"></div> <script> dojoConfig = { baseUrl: "mxclientsystem/dojo/", cacheBust: "635995334056127744", rtlRedirect: "index-rtl.html" }; </script> <script src="mxclientsystem/mxui/mxui.js?635995334056127744"></script> </body> </html>
1 answers

Have a look in the browser console logging (in Chrome CTRL + j) What does it say?

Most likely there are is one or more errors in your included widgets. When failing to load the widget it will not signal the Mendix lib that the page is ready to be displayed.

Sometimes it hard to find which widget that causes this issues, You could try to find it with the developer tools exceptions

It will paus and you can backtrack where the issue originates from. Be aware that the Mendix lib is also throwing error(s) on purpose when starting up.