MxAdmin login doesnt work for Free App

I upgraded my project from Mendix 5.21.4 to Mendix 6.5.1 because the Sandbox functionality would disappear as of June 1st for Mendix 5 apps. However, when I run my project in the new 'Free App' I can't login anymore (not even with MxAdmin) as it says that username and/or password is incorrect. I double checked the username and password of the administrator in the project security, but it doesn't work. The free app runs on the domain. Don't know if this is normal. Does anyone know how I can fix this? Edit 13-6-2016 I couldn't log in using my Mendix account, but I created a user account with admin permissions in a microflow after startup. I could use that account to create new users with the right permissions. Thanks for the help all!
4 answers

Did you try logging in with your Mendix account? In the Sandbox environment no MxAdmin account is created.


Hi Stephan,

There is another way to log in as Admin to your Free App.

This workaround worked for my Free App:

  1. Enable Demo users,
  2. Change Password for MxAdmin and name for that Demo user(Administrator) (I have changed mine to Admin),
  3. Login as Demo_Administrator,
  4. Disable Demo users,
  5. Log in as Admin and use that password.

Hi Stephan,

For the first time, password will not be get set for admin , so, give administration module access to another user and go to local users and change the password for admin. So, from then it starts working.


Hi, you've probably more than 10 'named' accounts in your free app. After the upgrade it is not allowed to have more than 10 users. You can build an after start-up MF to delete the accounts (except your mxadmin account).