Cloud foundry deployment fails with json error

We are trying to deploy a mendix app using cloud foundry. All seems to be well configured according to the Mendix instructions. We use: - IBM bluemix - Elephant DB - Amazon S3 bucket When deploying a simple MX example app "company expenses" from the modeler we get the following error: "Deployment to Cloud Foundry failed. Unable to Process JSON." Trying another example mendix app leads to the same error. What are we doing wrong?
3 answers

Does it work when deploying via the CF command line?

See for a how to.

My initial guess is that the environment variables are entered with quotes or asterisks or something like that.

What do the cloud foundry logs say?


It does work when deploying it from the CF command line. At first it gave an error, but that was due to the fact that I was using the default MxAdmin password ('1'). Seems that it must be a strong password before it is accepted by CF.

So, after changing it to a stronger password it worked fine. I can access the application and enter data.

Checking the deployment log, it still shows 3 errors: 2016-07-05T15:44:52.80+0200 [STG/0] ERR Cloning into '/tmp/buildpacks/cf-mendix-buildpack'... 2016-07-05T15:46:05.88+0200 [App/0] ERR Jul 05, 2016 1:46:05 PM java.util.prefs.FileSystemPreferences$1 run 2016-07-05T15:46:05.88+0200 [App/0] ERR INFO: Created user preferences directory.

Maybe this is a possible reason that I can still not deploy from the modeller itself. Still gives the same error as in the original post.


Hello René,

I think the most likely cause of this error would be the Cloud Foundry settings you entered in the Modeler. These settings are converted to the JSON format when deploying to Cloud Foundry.

Could it be that there's a strange character used in one of the Cloud Foundry settings (like the app name or space)? Or maybe in the password of the Cloud Foundry account you're using, or in the Mendix administrator password?