Modeler fails to start; Unable to initialize configuration system

Zojuist de trial version build 183 gedownload en geïnstalleerd. Helaas krijg ik bij het opstarten een unknown error en de vraag om een bug report in te dienen, maar er staat niet bij hoe. Hoe nu verder? De details: System.Configuration.ConfigurationErrorsException: Kan het configuratiesysteem niet initialiseren ---> System.Configuration.ConfigurationErrorsException: Niet-herkende configuratiesectie system.serviceModel (C:\Program Files\Mendix\ Trial\modeler\Modeler.exe.Config line 66) at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal) at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors) at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors() at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey) --- End of inner exception stack trace --- at System.Configuration.ConfigurationManager.PrepareConfigSystem() at System.Configuration.ConfigurationManager.RefreshSection(String sectionName) at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped) at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties) at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider) at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName) at System.Configuration.SettingsBase.get_Item(String propertyName) at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName) at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName) at Mendix.Modeler.Properties.Settings.get_JdkLocation() in c:\cygwin\home\autobuild\build\Mendix-2.5.1\modeler-svn\Modeler\Properties\Settings.Designer.cs:line 68 at Mendix.Modeler.ModelerApplicationContext.InitModeler(WorkerTaskInfo info) in c:\cygwin\home\autobuild\build\Mendix-2.5.1\modeler-svn\Modeler\Main\ModelerApplicationContext.cs:line 104 at Mendix.Modeler.Utility.WorkerTask.backgroundWorker_DoWork(Object sender, DoWorkEventArgs e) in c:\cygwin\home\autobuild\build\Mendix-2.5.1\modeler-svn\Mendix.Modeler.Utility\WorkerTask.cs:line 137 at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
6 answers

Hi Paul,

The error message you encountered is a generic .NET error message. It appears that there is a problem with your .NET installation. You can try to repair your installation by issuing the following commands on the command-line:

"%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe" /r /x

%windir%\Microsoft.NET\Framework\v3.5\WFServicesReg.exe /c

Afterwards, you need to uninstall the Modeler and reinstall it in a different directory. This is to ensure that the config file that you modified is not used. As you might have guessed, the section that you removed is actually needed to deploy your project.

We apologize for the inconvenience.


The Modeler Team


Hi Paul,

It is currently not possible for Trial members to report bugs through our Support Portal.

Posting it here on the Forum will suffice though, I'll get someone to look at it and we'll get back to you. If this is an actual bug we'll make sure it gets filed.


Do you have Microsoft .NET 3.5 and a recent JDK installed? If not, that could be it. Also please note the language of this forum is English.


I just tried something. Since the error message was about an unrecognized configuration section < system.serviceModel > in the Modeler.exe.config, I threw the whole tag out, including it's contents (lines 66-127). This is of course not the real solution, but I wanted to find out where this would lead.

I can start the modeler now and I can create a domain model, but I am unable to run the application. When I try, a new error message complains about the missing < system.serviceModel > section.

Anybody any idea?


That worked! Thanx!

The second command reported an error. I hope it didn't break anything. The modeler is now working and deploying.

C:\>%windir%\Microsoft.NET\Framework\v3.5\WFServicesReg.exe /c
Warning: CScriptMapsComponent::Initialize m_spAdminBase.CoCreateInstance failed. Error code: 0x80040154
Warning: CFxInstaller::SetupScriptMapsIIS6 Failed to initialize IIS6 APIs. Error code: 0x80040154
Warning: CFxInstaller::SetupScriptMaps Could not set script maps. Please install or reinstall IIS.


Hi Paul, you can file your bug at our Partner Portal.