CSS for Dropzone Widget Not Found when app deployed to cloud

I have an app that uses the Dropzone widget. Recently, I upgraded this app to Mx 6.6 (from 5.21). In 6.6, the widget uploads files without any problem, however the formatted text that says, "Drop Files Here to Upload" is unformatted, and when I upload a file, the widget shows some unexpected characters. The odd thing is that the widget displays this behavior when deployed in the Mendix Cloud (acceptance or production), but does not display the same issues when running in the modeler. When running the app from the modeler, the widget doesn't have any problems. In the cloud, the Chrome console shows the following on a page with the Dropzone widget: Any pointers as to how to resolve this are greatly appreciated!
4 answers

I think someone developed that widget on windows :)


doesn't work but https://lwcustomerp.mendixcloud.com/widgets/DropZone/widget/css/dropzone.css does

Note the capital Z in the directory name: this works fine when running on windows but not on linux. I've opened a pull request with a fix.


Blocking issue regarding dropzone widget fixed by replacing most recent widget from appstore by most recent widget from github (suggestion from Chris de Gelder!). So the latest version in the appstore is apparently not the right one to be used!


Have tried to download DropZone from GitHub but the styling is different than the version in the Appstore. User are used to the previous styling, is it possible to get the DropZone widget on Github (or Appstore) working in the MxCloud and with the styling from the Appstore DropZone widget?


I am using the DropZone widget in an app running in Mendix 6.10.0. I am encountering the same problems as described above. The css does not seem to work in the cloud environment of Mendix, but it is working locally. I have tried to implement the fix provided by Achiel, but its seem that in my widget 'DropZone' is allready spelled with a capital 'Z'. So this should not be the reason. Now im not sure where the real problem lies.


Has anyone encountered this issue before?


Any help is greatly appreciated :)