deep link giving wrong url while configuring after run in sandbox

Hi All, After running the application in sandbox tried to configure the deep link for particular microflow but when I entered deep link name as "Publisher", it is giving wrong url that is: " https://myapp.mxapps.iolink/author/". There is no slash between ".io" and the "link" and when I click on that link it is showing wrong address. When I correct the link by adding "/" then it is giving 404 error. It is working fine when I run the application locally. Please provide the solution. Thanks in advance. Sudarsan
1 answers

There is a difference in how the application url is being configured between your local machine and the cloud.

In your project settings (project explorer / Settings / environment) you have the localhost url specified. This URL ends with a / (problably http://localhost:8080/)

The cloud is configured differently, the URL for the application in the cloud is configured as: without the slash.

So if you would do url + suffix and suffix is: link/author/
ocally that would make http://localhost:8080/link/author/
but in the cloud that makes: https://myapp.mxapps.iolink/author/

The best most reliable way is that you'd check does the url already end with a slash if not( endsWith( $url, '/' ) ) then $url + '/' else $url
But the quickest way to get the same behavior locally and in the cloud is to remove the / from the url in your local environment settings.