incorrect toolbar navigation, buttons, menu items, error message texts...

Hi, One of our clients is user testing the app (which is on the Mendix cloud) and he's seeing menu items, some buttons and menu items with old or even the standard initial text when some of these widgest are created. E.g. buttons that display "microflow", a toolbar item that displays "New item" instead of "User guide", a menu item with an old text that has been recently updated, etc. There are even error messages that have no text, even though I can see them on my dev machine when connecting to the online version. The app is in test directory on Mendix servers and I have tried from different machines, with different browsers and I always see the correct text, but the customer gets these oddities. I have ask them to clear their cache and refresh everything, and they still get the same issues. Does anyone knows if it could be something with the way they connect, or as anyone came across something similar? Their browser of choice is IE, 7 or 8 and I have tested even on IE6 and I can still see all the correct text. As a note, the mda file never contained any buttons with text "Microflow", they either say "Save" or Cancel". Help?! LR.
1 answers

Are they using a different language? If so, maybe that language is outdated in your model.

Update: With 'they' I ment the customer(s) having the issue. And are you sure your user account is set to have English US language as well? Maybe your user account was created earlier. In your model, set your language back to English UK and then see if those buttons match the caption that your users are seeing.