Cant start Mendix service

I'm testing deployment of Mendix on Windows, following the steps in I went through all the steps up until starting the service from Mendix Service Console.exe. Problem: The 'Install service' button does nothing, the service does not appear in the list of services. I tried all possible credentials, and recently installed other services withpout problems. I then tried to install with Windows installutil: "installutil MendixService.exe" but this also failed: System.ComponentModel.Win32Exception: Invalid account name or password I have read the post at which also suggests it is a user credentials issue, but then for the user that installs the service (which would be me on my domain login), not the user that runs the service (a locally defined user with limited rights). Any ideas? Background: XP Pro SP3 SQL Server Express 2008 database accessible over TCP/IP .Net 3.5 SP1 (ASP.NET 2.0 SP1); Java 6 JRE I don't have a file yet To complicate matters: The installation with installutil did work once (the first attempt) but failed ever since (I did uninstall and reboots). In that one instance, the service was installed under NT_AUTHORTY\NetworkService; when I tried to start the service I got: [Event ID 7000] Error 1053: De service heeft de start- of stuuropdracht niet op de juiste wijze beantwoord. ("service did not properly respond to start or control") and [Event ID 7009] Time-out (30000 seconden) tijdens het wachten op het verbinden van deze service: Mendix 2.5.
2 answers

Well, I got it work, but not according to the book/docs.

I did a manual

sc create MendixService binPath= "C:\CISDeploymentTest\Mendix\Service\MendixService.exe"

(note the required space after BinPath= !) which gave me:

[SC] CreateService SUCCESS

Then I attempted to start the service from the Windows service manager with the local MendixUser account. (XP warned me that that user now got rights to start a service.) Result:

The service start failed. Event log messages:

Service cannot be started. System.Exception Mendix Runtime not started. The database is not synchronized with the model. bij Mendix.MendixService.Service.client_Ready(M2EEClient client, StartupInfo startupInfo) bij Mendix.MendixService.RuntimeRunner.Start(Boolean askToSyncDatabase, LogLevel autoSubscribeLogLevel) in C:\Mendix\2.5\Modeler\Mendix.Service\RuntimeRunner\RuntimeRunner.cs:regel 188 bij Mendix.MendixService.RuntimeRunner.Start() in C:\Mendix\2.5\Modeler\Mendix.Service\RuntimeRunner\RuntimeRunner.cs:regel 45 bij Mendix.MendixService.Service.OnStart(String[] args)

which is not surprising because there was no database yet. In the Mendix service console (, under Console I could now start the service.

Running http://localhost:8080 I could not login with the mxAdmin account, as warned for in the docs. Executing menu-item Advanced/Create or Update Admin User (an not a 'button'as says) gave me the error:

Password is not safe, also use non-alphanumeric characters.

So I went back, added a non-alphanumeric character, then I got:

Password is too similar to the username

These warnings should have been given much earlier in the Service Console/Common configuration section where I defined that password! I'll make a ticket for that.

Now it works!


Have you filled in DOMAIN_NAME\user_name instead of user_name?

Probably some info has been written to the Windows Event Log, see the Event Viewer at Administration Tools in Configuration Panel (in Dutch: Logboeken, Systeembeheer, Configuratiescherm).