advemail module is missing the code

Hi all, I downloaded Email Module 2.0 from app store. And tried to use "SendEmailMessage" M/F available under advemail/Use Me. When I run the Microflow it was returning me true always. When I tried to dig into the problem I realized that there are only two java files available under folder "javasource\advemail\actions" folder and file names were "" and "". And when I looked into the code I found the email send functionality is completely missing. I am sure that I downloaded the wizard correctly because I tried number of time and all the time I got only 2 java files in "action" folder. Can someone please let me know if it always comes without email send code and we need to write our own code in JAVA to send the email. As I am not comfortable in writing JAVA code. And when there is a wizard available on app store, I would assume it must have all the required code, rather than let the developer write the code. Otherwise why would one download any wizard when anyways developer needs to write all the code. And as we are using Mendix, it is not ideal to write the code for such a common functionality. And I don't see any satisfactory answer in Mendix Forum, which could direct me to how to use this wizard correctly without writing the code and start sending emails. Just to inform, I have already setup all the SMTP settings and all the information is correct like SMTP address and port number and everything as same information I have used in my other non- Mendix projects. I have tried everything to use this wizard and sorry to say I am not able to use it as it is not sending any email and the reason is simple it is missing the core email sending code. I don't write code in JAVA, And I don't want to write code in JAVA as I am using Mendix. And this is why we are using Mendix.. so that we don't need to write any code but just the business logic. so I am very helpless and tired now. Hope someone please help me.
1 answers

I get the correct java actions when downloading the module. Can you try removing the module and the module's folder in the java source and downloading it again?