web service response error

when I call a web service that takes an array of string as input and return array of string ,the consol shows: <faultstring>org.xml.sax.SAXException: Found character data inside an array element while deserializing</faultstring> what does that mean? The client provide us with the wsdl file that contains the following xml <s:element name="RunRESTActions"> - <s:complextype> - <s:sequence> <s:element minoccurs="0" maxoccurs="1" name="actionUrls" type="tns:ArrayOfString"/> </s:sequence> </s:complextype> </s:element> - <s:complextype name="ArrayOfString"> - <s:sequence> <s:element minoccurs="0" maxoccurs="unbounded" name="string" nillable="true" type="s:string"/> </s:sequence> </s:complextype> - <s:element name="RunRESTActionsResponse"> - <s:complextype> - <s:sequence> <s:element minoccurs="0" maxoccurs="1" name="RunRESTActionsResult" type="tns:ArrayOfString"/> </s:sequence> </s:complextype> </s:element> so I tried to simulate their web service by making a web service that take an array of string and return an array of string and It is working fine without any exception where its wsdl contains the following xml : <element name="getData"> − <complextype> − <sequence> <element maxoccurs="unbounded" name="strArray" type="xsd:string"/> </sequence> </complextype> </element> − <element name="getDataResponse"> − <complextype> − <sequence> <element maxoccurs="unbounded" name="getDataReturn" type="xsd:string"/> </sequence> </complextype> </element> and after search on google I found an answer says "I looked at a stub created by Axis's WSDL2JAVA tool and noticed that they construct a ArrayDeserializerFactory but without specifying the QName parmeter. I tried that and it worked. So just change your "new ArrayDeserializerFactory(xmlType)" to "new ArrayDeserializerFactory()". " So I don not know if the error is related to the client stub of mendix or their wsdl file is not standard ?
0 answers