Postgres version in the cloud

I tried to restore a backup of the cloud database to a local version but I get an unsupported version error. From the file header I can see version 8.3.12 and 8.4.8. I know there are problems when converting from 8.4 to 8.3. I thought that the cloud used postgres 8.3. But maybe this has changed. My question: which version does the cloud use and is this different between 2.5 versions of Mendix and 3.0 versions? [EDIT] From the answers of Roberto I have to edit my question a bit. 1)What is the standard version of postgres in the cloud? 2)Why are the psql version and the server version different in the cloud? 3)Who initialize the update of the postgres version in the cloud? 4)Are there differences between cloud 2.5 and cloud 3.0 versions?
2 answers

1) Default PostgreSQL version in the hosting environment is now 8.4, but there's still quite a bunch of applications that need a conversion of their database from 8.3 to 8.4.

2) If you get 'psql 8.4.8 server 8.3.12', chances are the server you're on is running both PostgreSQL 8.3 and 8.4, your application is using the 8.3 server and you're using the 8.4 version of the client utilities (dump/restore etc) which are backwards-compatible while working with an 8.3 database.

As long as you're using 8.4 on your local computer, you're fine. Mendix does not use any feature that prevents reading dumps made from an 8.4 mendix database into an 8.3 database server.

3) If you want an application that reports server version 8.3 to be upgraded to an 8.4 database, simply issue a support ticket on the application, so a little bit of downtime and reconfiguration can be planned together with you. If not, expect that you'll get a message from Mendix somewhere between now and october to cooperate to upgrade when the 'normal' transition project reaches your apps. :-)

4) Currently, there's no difference between 2.5 and 3.0 regarding PostgreSQL compatibility.


I think you can easily check what the version is of your postgres db-server. On the console (when you have started m2ee) just type psql

I then get: Welcome to psql 8.3.14, the PostgreSQL interactive terminal.

So I guess that on the env I checked it, the version is 8.3.14.
What I also know, is that I could (without any problems) restore a db in a postgres 9.0 db-server that I run locally.