Microflow Buttons not working in IFRAME

On a site running WordPress I have a page on which I include a Mendix form using an IFRAME. The source of the IFRAME is a DeepLink. The form has two buttons that both trigger a microflow. The page loads correctly in all browsers that I have tested, both on Windows and on Mac OS X. With Internet Explorer 8 I am having a strange problem though. The buttons don't work at all. The IFRAME works in Chrome, Firefox and Safari though without any problems, both on Windows and Mac OS X. When I access the form directly on the Mendix server without the IFRAME in Internet Explorer 8, the buttons work. Does anybody have a clue what causes this problem in Internet Explorer 8? I am experiencing this problem on Windows 7 as well as on Windows Server 2008. Update 22/SEP/2011 8:35AM: This morning I tried to include the application as a whole in an IFRAME, without using the DeepLink, in our WordPress site. This time the buttons in the form worked also in Internet Explorer 8 without problems. It looks like the issue is related to using a DeepLink in an IFRAME. Maybe this extra info will help to find a solution. By the way: Internet Explorer 8 is not the only version of IE that has this issue. It is also experienced in Internet Explorer 9.
0 answers