Emulate Cloud Security results in java.lang.NoClassDefFoundError error

Hi, When I run my project with "Emulate Cloud Security" switched on, I get this message: Could not find the main class: MyApp\TeamServer\MyCompany. Program will exit. java.lang.NoClassDefFoundError: MyApp\TeamServer\MyCompany Caused by: java.lang.ClassNotFoundException: MyApp\TeamServer\MyCompany at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) Exception in thread "main" The documentation tells me to run and test the application with the switch on before deploying to the cloud. What is causing this message? Regards, Paul
1 answers

There is a bug in version 3.1.1 of the framework, if you emulate cloud security we do not properly escape folder names when generating a policy file. This means this error will occur when you have spaces in the folders leading up to your project. If you can rename these folders or move your project this error should be solved.

This will be fixed in version 3.2 of the framework.