Converted project to Mendix 3.1.1 for test, now it wont start

Error I get when starting the project: Request action: start Message: Starting MxRuntime failed. Cause: Stack trace: com.mendix.m2ee.api.AdminException: Starting MxRuntime failed. at com.mendix.core.MxRuntime.y(SourceFile:243) Caused by: java.lang.NullPointerException at java.util.Date.getMillisOf( at java.util.Date.after( at kl.b(SourceFile:264) at kl.a(SourceFile:252) at kl.d(SourceFile:199) at kl.a(SourceFile:66) at com.mendix.core.MxRuntime.z(SourceFile:265) at com.mendix.core.MxRuntime.y(SourceFile:233) at com.mendix.core.MxRuntime.a(SourceFile:215) at com.mendix.core.MxRuntime.b(SourceFile:168) at fD.execute(SourceFile:54) at com.mendix.m2ee.server.handler.HttpAdminHandler.handle( at org.eclipse.jetty.server.handler.HandlerWrapper.handle( at org.eclipse.jetty.server.Server.handle( at org.eclipse.jetty.server.HttpConnection.handleRequest( at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete( at org.eclipse.jetty.http.HttpParser.parseNext( at org.eclipse.jetty.http.HttpParser.parseAvailable( at org.eclipse.jetty.server.HttpConnection.handle( at at org.eclipse.jetty.util.thread.QueuedThreadPool$ at
2 answers

Was this the first error you ever got or could it be that you already tried starting before and got a different error that time?

Anyway this error seems to be related to a missing date in the database saying when the database was last synchronized, I'm not sure how it could go missing though, so I am quite curious if you got this error the first time you tried to synchronize.

If you're not sure, try restoring your backup from this database and trying again to see what error you get. If it's the same then please file a ticket (include the 2.x database please, the data itself is not needed but the structure is)


Got some database sync errors, tried to work my way around them. Guess it wasn't to be. Isn't there a simple way around this? Editing some database field for example...

The lastsyncdate value is set by the way, in mendixsystem$version.