Mendix v3 challenges #2 - Installing Windows service

I have downloaded the latest Windows Service (to go with mendix 3.1.1) which is version 2.1. The configuration of this seems to be a bit different to earlier versions and not yet covered in the documentation. Things I found I had to do that were different and not in the docs: Instead of copying the server and runtime distributables from the Modeler installation directory, I had to download the zipped distributables from the Releases page and import them through the Windows Service Console Management tab. Instead of copying my model and web directories to the file structure, I had to create an mda archive and import that through the Service Console Management tab. So far so good I guess. The Windows service now seems to only have the option to run as a named user, not as a local system account. This was the first error I received - If I click on the Select User button I get an error *** Exception Text *** System.Runtime.InteropServices.COMException (0x80070057): IDsObjectPicker.Initialize failed at CubicOrange.Windows.Forms.ActiveDirectory.DirectoryObjectPickerDialog.Initialize() at CubicOrange.Windows.Forms.ActiveDirectory.DirectoryObjectPickerDialog.RunDialog(IntPtr hwndOwner) at System.Windows.Forms.CommonDialog.ShowDialog(IWin32Window owner) at Mendix.MendixService.Management.ServiceControl.btnSelectUser_Click(Object sender, EventArgs e) in C:\Mendix\3.0\Platform\modeler\Mendix.Service\ServiceTester\Management\ServiceControl.cs:line 51 at System.Windows.Forms.Control.OnClick(EventArgs e) at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ButtonBase.WndProc(Message& m) at System.Windows.Forms.Button.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) So instead of trying to select a user through a dialog (is it assuming that Active Directory is being used rather than local users?), I just typed in a user name and password. I'm not sure if this will work... At that point all information seems to be complete, so I tried to run the application in the Service Console. When I click on the Start button I get an error immediately from the Java Virtual Machine Launcher: Could not find the main class: com.mendix.m2ee.server.HttpAdminAppContainer. Program will exit. I checked the JRE configured under Common Configuration (jre6 30 64bit). I tried changing it to jre7, and although that is not supported, this error was avoided... but another one happens a little later: The server failed to start. See details for the server log. Error: Could not find or load main class: C:.Apps.MxESS.Application.model.lib.i18n That directory does exist. Are there any configuration steps that I have missed? Edit: Well, it looks like the cause of the second error was a VM argument carried across from the 2.5.8 version: -cp "C:/Apps/MxESS/Application/model/lib/*" Removing that argument allows the service to start (using jre6) - now if only I could remember why it was there in the first place. Was it added for a widget or module - License Pool Manager, LDAP or something like that?
1 answers

You said that the changes in the latest Mendix Windows Service are not covered in the documentation. That's not true. When we released version 2.1, the documentation was updated too. See (under 'Management') and for the documentation about updating your application and adding server files.

All version changes are visible in the changelog (see the release notes in the Release tab of the Support Portal) and placed in a forum post ( too. In the changelog is written that it is not possible to use a system account (like Local System) anymore.

Thank you for reporting the error of the Select User dialog. We already received a ticket of such an error and we will fix that bug.

Maybe you have added the VM argument because the userlib folder was not correctly linked in versions before 1.0.6 (which was released on November 23, 2010) of the Mendix Windows Service.