IIS7 XAS redirect issue

Hi, after strugling with IIS6 we decided to try IIS7, with some futher issues. It looks like XAS requests are not being forwarded, after following the documentation at "https://world.mendix.com/display/howto30/Set+up+a+separate+Internet+Information+Services+server". Our mendix runtime service, v2.1, is running on port 81. We can access this as expected. In IIS7: -Added our projects' web directory as a site in IIS7, listening on port 80. -Added a virtual directory to the mxclientsystem, with alias mxclientsystem. -Added the ManagedFusion.rewriter.dll and pdb files to the bin folder in our web directory. -Added index.html as a default site and removed the .asp(x) ones. -Added the ManagedFusion.Rewriter.txt to the web root, with the following content (tried with 'localhost' and ''): RewriteEngine On RewriteCond %{QUERY_STRING} ^(.+)$ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond $1 !^ui RewriteCond $1 !^forms RewriteCond $1 !^mxclientsystem RewriteCond $1 !^widgets RewriteRule ^/?(.*)$1?%1 [P,L,R] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond $1 !^ui RewriteCond $1 !^forms RewriteCond $1 !^mxclientsystem RewriteCond $1 !^widgets RewriteRule ^/?(.*)$1 [P,R] -Our web.config at the ends looks like the following: <?xml version="1.0" encoding="UTF-8"?> <configuration> <configSections> <section name="managedFusion.rewriter" type="ManagedFusion.Rewriter.Configuration.ManagedFusionRewriterSectionGroup" /> </configSections> <managedFusion.rewriter xmlns="http://managedfusion.com/xsd/managedFusion/rewriter" /> <system.webServer> <validation validateIntegratedModeConfiguration="false" /> <modules runAllManagedModulesForAllRequests="true"> <add name="RewriterModule" type="ManagedFusion.Rewriter.RewriterModule, ManagedFusion.Rewriter" /> </modules> <handlers> <add name="RewriterProxyHandler" preCondition="integratedMode" verb="*" path="RewriterProxy.axd" type="System.Web.HttpForbiddenHandler, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" /> </handlers> <urlCompression doStaticCompression="true" doDynamicCompression="true" /> <staticContent> <mimeMap fileExtension=".mxf" mimeType="text/xml" /> <mimeMap fileExtension=".json" mimeType="application/json" /> </staticContent> </system.webServer> <location path="xas"> <system.webServer> <httpErrors errorMode="Detailed" /> </system.webServer> </location> </configuration> The one step that does elude me is "you must disable the IIS custom errors for the 'xas' requests", we tried adding the following as a child to the 'configuration' element: <system.web> <customErrors mode="Off"/> </system.web> What we are obeserving as we access IIS7(port 80) server: -We are getting all the static content (mendix.js, dojo.js, etc.). -There is post to xas with URL with command "getcurrentuser", which returns a populated/non-erroneous JSON result, even there is a XASSESSIONID and alot of other things in the JSON. -There is post to xas with URL, which has a response of 302(and sometimes 200), but its response header contains a property called 'Location' with value '/login.aspx?ReturnUrl=%2fxas%2f'. Directly after this post there is a Get with URL '', which we do not see when going directly to the mendix server (port 81) -The exact same behaviour as mentioned with #active_modules is observed with a post to xas with URL These two posts and gets are the last requests we see, afterwards resulting in a semi empty login/index screen. (no login details) Please ask for any more information or clarity on any of this, help greatly appreciated.
1 answers

It seems that forms authentication is enabled, because of the 302 responses with location value '/login.aspx?ReturnUrl...'.

To see if it is enabled, go to Internet Information Services Manager, click on the website and click on Authentication. Disable Forms Authentication if it is enabled.