Webservices fail after upgrade to version 3.2.1.

We do experience a problem in calling the SAP ERP backend in the 3.2.1 modeller. A project initially created in v3.0 beta of the modeller worked completely fine in that version. However after migration to the newer version 3.2.1., suddenly the webservice calls return: WSS1601: Security Requirements not met - Transport binding configured in policy We can solve the issue by adapting the webservice on the SAP backend by changing the configuration. However one would not expect this to be necessary and to be able to upgrade to a newer mendix business modeller version without issues. The problem is suspected in the newer webservices-rt.jar libraries now used in the modeller v3.2.1.
1 answers

Because something worked in a beta version doesn't mean it's correct. From the beta we did upgrade our webservices implementation and I'd say the new implementation is much better than the previous one. Updating your framework shouldn't normally cause issues but if something was simply wrong in the past then we don't want to keep such behavior. I don't know if that is the case here but I would certainly consider it.