JMS MessageListener - EOFException

I have been sitting with this weird issue for 2 days now and I have tried loads of stuff. Basically I have microflow selected in the "After startup" that runs a Java Action which initializes a connection to JMS (ActiveMQ Queue to be exact). Everything works fine. Some external system puts some data on the Queue - the "onMessage" fires in my MessageListener and I can log the data or even pass it through to a microflow. Problem comes in the moment I try and commit en Entity after the "onMessage" has fired my Mendix app hangs. When I stop my Mendix app it tries to shut down for ages and then pops up with a "Force quit" dialog. I have tried committing (Core.commit) in the "onMessage" or in a microflow that I call from the "onMessage" and same result. If I change my app to grab data from the JMS Queue when I press a button, everything works fine, but when I start up a JMS listener and then commit something it hangs. I put all log levels on TRACE and got a "Jetty" - "EOF - - null" about 4 times when I click "search" on the screen and then the app hangs. Basically any ideas on how I can see more output, or how I can see what it is that is going wrong will be appreciated. Sorry for the long winded post
1 answers

Ok so I got this to NOT happen

When I start up the JMS listener I pass in the context using "getContext()". This seems to cause the issue.

Instead when "onMessage" fires I do "Core.login()" and get a new Context that way. When I use that new context everything works fine.

So guess I will have to understand how the contexts work