Webservice Constant URL

Hi, We rolled out a new version of our application two days ago. Part of the new release was a web service upgrade, and included a new URL. The program was thoroughly tested and everything worked perfectly. But when we went into production, I uninstalled the service, updated the URL constant under Application Constants to the production version of the new webservice, and reloaded the application, installed and started the service. The URL was still pointing to the UAT/Test URL and not the production URL. After vigorously trying to figure the problem out, I eventually changed the URL in the modeler to point to the production web service, rebuilt everything and uploaded the new version again. Then it worked. Did I do it wrong the first time round? Should the web service not have called the production URL that was specified in the service console? When opening the web service, under Services, I have selected the Constant upon the initial web service import. When I imported the new webservice, the "Location constant" got set to (none), and I did not notice this, as the Name and Location fields were still populated and it did not catch my eye. After re-selecting the constant, I've got a working solution again... So, I thought I should post it here as an informative piece, just in case someone pulls the same stunt as me... :) Hope it keeps someone from making the same mistake. Kind Regards Frikkie
0 answers