Version missmatch on Deeplink?

As I still am experiencing issues with the Deeplink Module I checked the appstore and see it has version 2.1.3 As I was using version 2.1.2 I Downloaded from the Appstore and opted to "replace" the existing module ...(assuming it could not get worse)... Strangly enough, once downloaded, the Module itself keeps telling me it is 2.1.2 ?? It also still creates the error Blockquote java.lang.IllegalArgumentException: Global identifier should not be null or empty at hE.<init>(SourceFile:89) at com.mendix.core.Core.createMendixIdentifier(SourceFile:1665) at deeplink.actions.StartDeeplinkJava$DeepLinkHandler.serveDeeplink( at deeplink.actions.StartDeeplinkJava$DeepLinkHandler.processRequest( at iG.a(SourceFile:71)
1 answers

Hi Lex,

I didn't check the module for you, but some lucky guesses, hope it helps: - have you cleaned the deeplink folder/files in the javasource folder of your project? - have you cleaned the deployment folder?

Reason for asking is that I experienced problems some longer time ago, and the resolution was that some old java-file resided somewhere. After removal of all stuff and again importing the newest version, things worked again.

If it still doesn't work, I would recommend checking this issue in a new separate project. When then problems persist, it starts to smell a bit... :-)