FusionCharts not working

Hi, i've installed the FusionCharts v3.0 module into my project, and i can't seem to be able to display any graph. I've included a link on my project to the example pages, and when i click on a button to display a chart, it takes me to a page that has a form header "Chart", a cancel button, but no chart. How can i fix this?
2 answers

This module works OK for me in my project, but I had started with an earlier version and manually updated it to the latest version, so to try to reproduce your issue I imported the latest version into a new project and had the same issues that you report.

After investigating, it seems that the reason that the graphs are not displaying is that you have no access to the sample data. You need to go into the domain model and set data access for all the entities (on the Access Rules tab). Either set access for the role Everyone which comes with the module, or add your own roles and define their access rules. After that is done you should be able to see the sample graphs OK.

You may also wish to log a support issue to ask that the sample role included in the module be given access to the data, so it works when the security level is set to production.


Thanks to David i have managed to find out what was causing the problem. The issue was my browser's flash addon that is having some kind of issue rendering the chart (Firefox). Before i had changed the entities' access rules, i tried opening the examples on another browser but as David said i didn't have permission to access the data, causing the chart not to be displayed. I tried opening the project on firefox after changing the access rules, but the chart didn't display correctly, however, opening the project on another browser (Chrome) did the trick.

Edit: After some searching, i found out that the latest version of flash (11.3) is quite buggy. Downgrading to a previous version fixed the problem on firefox.