Grid bug on Migration of Mendix v2 to v3

We've upgraded our version Mendix Application to version 3.2.1. All seems well, except we cannot select a single line in the datagrids. We can double click them and invoke the default button action, but single selects are broken. I've checked both the server console and the firebug console for request and/or javascript issues, but none seem to appear. What we did pick up however, was that the selection was working when accessing the application directly on Port 8080; which is funny, since this setup worked with version of Mendix, yet the clue seemed to be pointing to IIS as grid selections fail on port 80. So I nuked the IIS Site and recreated it. It didn't seem to work. So before I log a support ticket, I was wondering if anybody else have experienced something like this? Here is a little video explanation of whats going on: link text
1 answers

Just out of curiosity. Did you try different browsers? Try it with IE. I have seen something like this. In that case all worked in IE but moving to firefox or chrome it did not with similair results as you have.