Mendix 4.1.1 issue: Date pickers not available for date fields

Today I installed Mendix Modeler 4.1.1 and converted my project. Everything looked and worked fine, until I suddenly noticed after a few hours work that the date pickers have vanished from all the forms for all date fields. I noticed the issue on my locally deployed server that is started from the Modeler as well as on our acceptance environment where I deployed an unversioned release of the project. I am experiencing the issue in all browsers that I've tried and on Mac and Windows computers. When I inspect the HTML code of the forms I have noticed that the code that should display the date picker is missing completely. Our production server still runs on version 4.1.0, so I was able to cut out the missing HTML from a form that is running in production: <div class="mendixFormDatePicker_buttonPick" dojoattachpoint="iconNode"> <span class="mendixFormDatePicker_buttonTextIcon">►</span> </div> This HTML code above is not generated in version 4.1.1. I also tried to run our project with one of the default themes, to no avail: still no date pickers. Is there something I can do to fix this on our end? I hope so, otherwise I have to go back version 4.1.0 and redo everything I created in 4.1.1 today... :-(
2 answers

This was a bug in 4.1.1 unrelated to conversion but related to a custom timezone format (for a specific language). It will be fixed in 4.2.


I'm using a new project created in 4.1.1. which has datepicker as expected. So your issue has come up when converting, but why??

Below some options which may work:

  1. Clean deployment directory before creating a deployment archive
  2. Get one form with the missing datepicker and remove the field from the form, and add a new datetime field to the form using the 4.1.1. version.
  3. Rebuild the complete form from scratch and point all buttons/microflows to use the new form. :(
  4. Convert back to 4.1.0 and redo your work from today :(