synchronising database

Hi, I've migrated a project from v322 to v422 and synchonising the database is taken forever. It's only going through 1300 data definitions, which is not excessive, but stays there for well over 30 minutes and doesn't stop. We cannot stop it. If we run with built in DB, works fine, but when linked to real DB, we seem to hang on the synch. No errors, no logs, nothing. All synchs from previous version migrations worked well. Any one seen this before? Any ideas? I've restarted app, server, machine, etc, no good result. LR.
4 answers

It's not hanging, it's still doing stuff, it just takes a while. Check if there is still actual harddisk/network and cpu activity if you want to be sure.

If you killed the process in the middle then you will have to restore the original database though.

Also see


To be inspired: In one of our projects it took about 20 hours. Also the database on the file system grew from 50 to 167GB. With a database backup and restore we fixed the size issue.

It took a while but after the conversion everything works just fine.

You can watch progress with tools like PG Admin for Postgres databases.


Have you tried running the SQL update commands manually? When you get the pop-up prompting you to synchronise the database, click on the Details button and copy the SQL code. Then Cancel the operation.

Then, go to your favorite Database client and run those SQL commands manually - if there are any issues you should get more details


For ma same issue . I developed one app in 4.3.2 but i am not able to deploy it to could . It says unknown error and no details .

2013-01-29 06:00:05.402 INFO - M2EE: Stopping MxRuntime now.
2013-01-29 06:00:05.402 INFO - Core: The MxRuntime is shutting down now...
2013-01-29 06:00:05.402 INFO - ActionManager: Shutting down ActionManager now, running actions will be terminated...
2013-01-29 06:00:05.503 INFO - Core: The MxRuntime is now stopped.
2013-01-29 06:00:05.567 INFO - M2EE: Stopping Logging and AdminServer now.
2013-01-29 06:00:06.485 INFO - M2EE: Logging to file: /srv/cloud/slots/tr10069/deploy/data/log/logging.log, max size: 2048KiB, max rotation: 10
2013-01-29 06:00:07.649 INFO - M2EE: appnode-unadon-tr10069 connected.
2013-01-29 06:00:07.668 INFO - M2EE: Registered '' as cloud portal contact
2013-01-29 06:00:08.146 INFO - Core: Mendix Runtime 4.3.2 (build 758). Copyright © 2003-2012 Mendix bv. All rights reserved.
2013-01-29 06:00:11.741 INFO - ConnectionBus: Database: PostgreSQL 8.4.9, name: 'dbnode-unadon-db69'
Url: jdbc:postgresql://
Driver: PostgreSQL Native Driver PostgreSQL 9.1 JDBC4 (build 902)