Web service search for existing objects causes exception

Hello, I've imported a web service into my project and I am using it to retrieve a list of objects. When I run this web service with the option to create all objects that are retrieved from the web service it works fine. However when I run it with the option to search for existing objects (based on an ID in the objects retrieved from the web service) I get the following exception (I've cut part of the exception off to focus on the readable parts): ld: java.util.MissingFormatArgumentException: Format specifier 's' at MyFirstModule.get_monitor_list (CallWebservice : 'Call web service 'getMonitorList'') Advanced stacktrace: at mq.a(SourceFile:187) Caused by: com.mendix.systemwideinterfaces.MendixRuntimeException: java.util.MissingFormatArgumentException: Format specifier 's' at nW.a(SourceFile:114) Caused by: java.util.MissingFormatArgumentException: Format specifier 's' at java.util.Formatter.format(Formatter.java:2432) at java.util.Formatter.format(Formatter.java:2367) at java.lang.String.format(String.java:2769) at com.mendix.core.Core.retrieveXPathQueryEscaped(SourceFile:1240) at com.mendix.core.Core.retrieveXPathQueryEscaped(SourceFile:1288) Has anyone got an idea what the problem might be? Thanks! ======== UPDATE: This has been accepted by Mendix support as a bug.
1 answers

While i am not sure, based on this error my guess would be that the key you use to search the item is sometimes empty resulting in this error. Are you sure the key you use to search the object is always present?

Maby you could present us with the complete stacktrace, so that we can find out.