Imported Webservice problem with content type header or charset

I'm having a problem calling an external webservice from a microflow. The webservice call faults with message: "SOAP-ENV:ClinetRequest is missing the Content type header charset parameter, or charset is not UTF-8" I get perfect results when I call the same webservice from soapUI. So there must be something wrong in the way I declare the soap interface in the business modeler, but I'm clueless. Is there a way I can see which soap-request actually is send by the system? Is there anybody who can give me some directions to proceed? Cheers, Paul Janssen (Ad\venture-media)
6 answers

Paul, you can see your soap request in the XAS console.


 2:       Advanced ;
    7:       Set console log level ;
      4:       WEBSERVICES [INFO] ;
        2:       DEBUG.

When a webservice is called, the SOAP request will be printed in the console.

Good luck!

About the charset, Which modelere version are you using? I know there is a bug fix in the newer versions (2.4.4) where the charset is set automaticly to UTF-8.


Tx Floor, for the reply. I'm using version, so the charset should be fine. I'll try the console option.


Having a little progress with calling that external webservice, but still get the same error ("SOAP-ENV:ClientRequest is missing the Content type header charset parameter, or charset is not UTF-8")

I have logged the webservice SOAP envelop. It contains a correct header. I get a correct result when running it form soapUI ("user not allowed to log in").

The SOAP-envelop is: <soapenv:envelope xmlns:xsd="" xmlns:soapenv="" xmlns:xsi=""><soapenv:header><ns1:headerauthenticate xmlns:ns1=""><ns1:reactid>?</ns1:reactid></ns1:headerauthenticate></soapenv:header><soapenv:body><axis2ns1:businesssearchpostcode xmlns:axis2ns1=""><axis2ns1:nbcode>4105</axis2ns1:nbcode><axis2ns1:lettercomb>GH</axis2ns1:lettercomb><axis2ns1:houseno>20</axis2ns1:houseno><axis2ns1:housenoaddition></axis2ns1:housenoaddition><axis2ns1:page>0</axis2ns1:page></axis2ns1:businesssearchpostcode></soapenv:body></soapenv:envelope>

Any ideas why it is still giving the fault when calling it from within the mendix system?


Are you getting the complete soap envelope? I usually get an envelope that starts with

<?xml version="1.0" encoding="utf-8"?>"

Also, how are you building the soap envelope? Are you using "Default" or "Custom"? Lastly: are you simply copy/pasting the envelope that you pasted above into soapUI? Because it's possible that soapui automagically prefixes every request with some kind of encoding. In that case: could you provide us with some info on the 'exact' request that soapUI sends?


We found a possible cause for this issue and have added this information to your ticket in MXDN, you can stay updated on the progress through MXDN.


Hi Bas,

I have looked in the ticket, but the only thing I see is a comment refering to this article. Am I wrong?