Strange Problem

Hello, We’ve encountered a strange issue, which occurred within an on change microflow in a form. The microflow should populate another attribute displayed within the same form. Strangely, it didn’t populate this attribute although the commit and refresh behaviour should definitely trigger the change. One of my colleagues implemented a “fix” by adding another Commit & Refresh action within the microflow. This had the issue resolved, but when we tried it on another computer the population of the attribute still didn’t occur. Even more strange is the fact that the next day, the “fix” stopped working on the computer of my colleague as well. We reverted all changes and did the same “fix” again, which eventually had the same result. It worked on one computer, did not work on another, next day it worked on none of the computers. The entity that is manipulated in the form has come from an inheritance split. Commits and refreshes occur in the logical places. We suspect it has something to do with cached memory, but we can’t put a finger on it. Any input would be very helpful. Edit 1: We have noticed that the deployed version on the mendix cloud (test) works as intended but the local does not. When using the model from test the problem still occurs locally. Edit 2: The cloud test server upon no changes doesn't work too. Edit 3: We stepped through debug and you can see that the entities get changed with the correct values etc but the form does not show it. Unless you close the form and reopen it.
2 answers

This was fixed by having an additional dataview calling a micro flow to re-retrieve the data.
Was very strange.


Did you check entity access? Try opening the domain model and go to the entity and right click on the attribute which should change..try 'find usages' to see where this attribute is used and/or 'find changes in microflows' to see which microflows change the attribute. Could be that 2 (or more) microflows are interfering each other.

You could clean your deployment directory (menu Project, clean deployment directory) and remove browser cache (CTRL + SHIFT + DEL)