Deeplink fails from MS Word

Hi there, We have a deeplink as follows [] This link works perfectly when navigated to directly by typing the address in the browser or by clicking on a hyperlink in HTML. But when we create a hyperlink in Word with the url provided, the deeplink fails and it just goes to [] Is Word doing something with the URL before it reaches the browser? Thanks,
2 answers

Deeplink sets cookies and does a redirect (303). From MSWord it looks like that the cookies is not set so Mendix will show you the login page. File a support ticket.


I ran into this question while searching for another, but I'm answering anyway because I just fixed this problem yesterday. The new version of the deeplink module in the app store has this fix, so if you update your deep link module the problem should be solved.

Technical details:

This is caused by a weird limitation/"feature" in Word, see also

The issue is that when you click on a link in Word, it first tries to load the link and follow any redirects. Word uses its own cookies for this, so the deeplink is prepared for a new anonymous session. It will follow any redirects and once no further redirects are encountered, it will open a browser window with the final URL that it encountered (in this case index.html). The browser will use its own cookies to get back to your actual user session, and will start at index.html (not your deeplink URL) So, the browser does not actually open the deeplink properly, and the deeplink-home microflow cannot find the pending link since that was prepared for a different session.(the Word one).

The solution was to ignore any requests made by word (through the user-agent header) in the deeplink module. This tricks word into thinking there are no more redirects, and will cause it to open the original deeplink URL in the browser.