Deployment error when using deeplink

I have added deeplink to my application, it works just fine locally but deployment in the cloud fails. A few days ago I did get this error on the call to DeepLinkHome: "A microflow/rule that does not apply entity access can only call microflows/rules that also do not apply entity access." I could not find anything on the forum about this error in relation to deeplink. In the end, deleting the call and then inserting it again solved the error and the application worked again locally including deeplink. But deploy still failed. Removing the call to DeepLinkHome solved the deployment error. This morning I tried importing the deeplink module again, there are a few layout issues, the layouts have been moved into subfolders, while the deeplink pages refer to layouts in the root of the layouts. These are easy enough to fix to get the application error free. After the import of the module, I got the microflow entity access error again. And it went away again after recreating the call to DeepLinkHome. I checked the documentation on configuring deep link many times. Still I hope I missed something that causes the problems.
2 answers

The error you mention is not really resolved by recreating the microflow. When you look at the DeepLinkHome microflow, it has a "yellow" background opposed to the regaluar "white" background of most microflows. This is because there is an extra layer of security "apply entity access" set to true. You can find this setting looking to the properties of your microflow (standard displayed on the right side of your screen).

All the top laying microflows (the onces that use the DeepLinkHome as a Subflow), also need to have this setting set to true. What your error message is saying, is that a microflow with no entity access calls a microflow with entity access and this is not allowed. But as far as I know, you need entity access enabled in order for the module to work properly.

Hope this helps you out!


This error usually shows up when the project is in production mode, if the project is set to Prototype/Off,then the error would not be showing