No constructor found for widget

Within a new application I have Running on Acceptance, it seems that all my widgets in Mx5 are corrupt. Every widget on my anonymous login page (Static Image and Login Widget), all give me the same error "No constructor found for widget". I've never experienced this within my local environment, neither on another application (although this is the first Mx5 app i Run in the Standard Cloud). Anyone having experienced this as well?
3 answers

The "No constructor found for widget" is a common error when dealing with custom widgets in development. Before diving into specific custom widgets or code it's always a good idea to check whether or not it's a browser cache issue. Especially when working on multiple projects or multiple versions (in development) of a custom widget.

Use a browser with an empty cache and check if the problem still occurs. If it doesn't, I wouldn't worry about it. If it does, then it's time to dive into the details.


The regular functionality "Create Deployment Package" seems to fail within my project. The "widgets.js" file is not built up properly and seems corrupt. As a fix, I changed the .mdk file to .zip, unzipped, replaced the "widgets.js" - Found in the "Web -> widgets" directory - with the one from my deployment directory - "Deployment -> web -> widgets" - and created a new "widgets.js.gz", replacing the old one. This did the trick.


For anyone who finds this thread and experiencing the ‘Constructor not found’ issue, it’s often the case that a widget is not perfectly working in Internet Explorer 11. Please check the JS console in IE to find out which widget is causing the problems. In my case it was the ClipboardTextCopy widget which was not compatible. There is a pull-request with a version that works, but it seems that the Github repo is abandoned… (Check for a working version: