Migrating from Mx 4.6.1 to 5.3.1

Hi All, I am trying to migrate one of my test app to Mx 5.3.1 before migrating the production one, all modules are updated (MxModel Reflection, Community Commons and Excel Importer) using the Mx 5 conversion wizard and in the end it says " before you can press Next, all the errors in your project should be solved. Only one error should remain; the one that says you have to complete the conversion wizard". It said me to close the wizard and solve all the errors and then double click on the error which is left, I solved all the errors and then double clicked error of conversion wizard, it took me to Mx 5 conversion wizard and said it will now migrate Java libraries from Mx 4 to Mx 5. The issue is that the migration of Java libraries is not successful and it says that "An error occurred while running the migration". When I go to console to see the details there is nothing and no details of error are provided, I think this is issue with some Java compilation but don't have any clue how to solve this issue. Please can anyone help me out. Thanks in advance. Note: Before converting to Mx 5.3.1, I converted my project from 4.6.1 to 4.8.1 the latest version of Mx 4 as recommended by Mendix and then tried to convert to Mx 5.3.1 but still getting same error.
1 answers

I recently had the exact same occur and was able to solve it by cleaning up the project directory. In my case there were a bunch of widget files in the userlib directory apparently causing some errors. I would suggest to take a look at your /resources/, /userlib/ and /widgets/ directory to look for possible duplicate files.

Alternatively, file a ticket in the support portal as Mendix should display a proper error message on what is causing it not to be able to complete the conversion.