Java heap error when running 5.6.0 project

Running an existing app locally from modeler 5.6.0 returns a javaheapspace error. I increased heapspace up to 2000MB, still the same error. Can anyone explain what causes the error? In Mendix 5.5. all worked fine. ============================ Buildfile: C:\Users\Lia\Documents\Testapp-main\deployment\build_core.xml compile: [javac] Compiling 2 source files to C:\Users\Lia\Documents\Testapp-main\deployment\run\bin [javac] Note: C:\Users\Lia\Documents\Testapp-main\javasource\com\mendix\core\ uses unchecked or unsafe operations. [javac] Note: Recompile with -Xlint:unchecked for details. build: [bnd] # addAll 'deployment/run/bnd.bnd' with , BUILD FAILED C:\Users\Lia\Documents\Testapp-main\deployment\build_core.xml:45: The following error occurred while executing this line: C:\Users\Lia\Documents\Testapp-main\deployment\run\bndbuild.xml:9: java.lang.OutOfMemoryError: Java heap space at java.util.Arrays.copyOf( at at at at aQute.bnd.osgi.EmbeddedResource.copy( at aQute.bnd.osgi.EmbeddedResource.collect( at at at aQute.bnd.osgi.Analyzer.analyzeBundleClasspath( at aQute.bnd.osgi.Analyzer.analyze( at aQute.bnd.osgi.Builder.analyze( at aQute.bnd.osgi.Analyzer.calcManifest( at at aQute.bnd.osgi.Builder.builds( at aQute.bnd.ant.BndTask.executeBackwardCompatible( at aQute.bnd.ant.BndTask.execute( at at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at at at at at at at at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( Total time: 38 seconds
1 answers

Our cusomer was running an older java 1.7.0 version.

We updated the javaversion to the latest 1.7.0_65 version. For the 64bits laptops installing the 64 bits java version solved the problem.

For the 32bits PC's the problem still exists also after installing the 32bits 1.7.0_65 version.