dojo.js cachebust

Hi, Has anyone experienced the cachebust error "The cacheBust parameter is missing....." only occuring when referencing dojo.js in 5.21.5? For example, this code below will trigger that error for me only when the dojo.js script is there. It worked fine in 5.15.1 but trying to upgrade to 5.21.5. Thanks! <!doctype html> <html> <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> <title>Mendix 5</title> <meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1, maximum-scale=1"> <link rel="stylesheet" href="lib/bootstrap/css/bootstrap.min.css?{{cachebust}}"> <link rel="stylesheet" href="mxclientsystem/mxui/ui/mxui.css?{{cachebust}}"> <link rel="stylesheet" href="css/theme.css?{{cachebust}}"> <script type="text/javascript" src="mxclientsystem/dojo/dojo.js?{{cachebust}}"></script> </head> <body dir="ltr"> <div id="content"></div> <script> dojoConfig = { baseUrl: "mxclientsystem/dojo/", cacheBust: "{{cachebust}}", rtlRedirect: "index-rtl.html" }; </script> <script src="mxclientsystem/mxui/mxui.js?{{cachebust}}"></script> </body> </html>
1 answers

I found the answer. Even though the placement of the dojo.js was ok in 5.15 to be above the dojoconfig - in 5.21.5 I had to move the placement of the dojo.js to be below the dojoconfig. That fixed it.