How to reverse a Business Modeler version commit?

Greetings, I have a client that jumped ahead and updated their Business Modeler to 5.10 final release (previously on 5.9.1). Upon doing so, the custom SAML broke and the SSO functionality is no longer routing correctly. She committed the change to the team server and deployed to test. We would like to "undo" that and revert back to 5.9.1 where it worked until further testing can be completed, but we don't know how to stop the teamserver from requiring everyone to use the new 5.10 version.
4 answers

To roll back to a previous version, take the following steps.

  • Install TortoiseSVN if you haven't got it yet
    * 1.7 (for Mendix 7) . See
    * 1.9 or newer (for Mendix 8). See  
  • Close the Modeler that has the project open.
  • Navigate to the directory that contains the project directory of the project you are interested in.
  • Right-click on the project directory.
  • Choose TortoiseSVN > Show log.
  • Right-click on the revision you want to go back to go. The changes from the selected revision will still be there. So in the case of reversing a conversion, you select the revision just below the one that does the conversion.
  • Choose 'Revert to this revision'.
  • Click 'Revert' and then "OK".
  • Right-click on the project directory again.
  • Choose TortoiseSVN > Commit.
  • Type a commit message and click 'OK'.

Now you can open the project in the older version again!



In version 5.10 of the Modeler, go to the Team menu and select Reverse Merge Changes. Pick the version(s) you would like to reverse, and let the modeler reverse merge those changes. Then save, your changes, but don't commit. Close the project and close 5.10 Modeler. Open 5.9.1 Modeler and you should be able to open the project again.

If that doesn't work, creating a new branch from a previous version as Ronald mentioned is the way to go..



There are a couple of things you can do. Most is explained here.

Or you create a new branch from the previous version and work on that branch till you got it fixed. Then you can merge the branch back to the main line.




This issue has been investigated and will be solved in an upcoming release. Please file a ticket if you run into this so we can offer you a workaround.

@Nolan, Ivo: you should both have received a reply from me in your ticket.