When SEF changes you need to enable again the SEF?

This could be standard behaviour as intended, but I find it a bit strange. We experience that when we change a SEF (Scheduled Event Flow) we specificly need to enable it again when deploying. I think this behaviour has recently changed, because it used to be that once enabled it would always stay enabled unless you removed the SEF. We are now once and a while surprised that something is not running only because we worked on a SEF and after the deploy it is suddenly not enabled anymore. Regards, Ronald
1 answers

The "Enabled" checkbox applies only when the app is running locally in modeler. On the deployment server, only what you specify in the yaml file will matter. https://world.mendix.com/display/howto40/Manage+scheduled+events

If your yaml file did say "ALL", do include a log statement at the beginning in your microflow, so that you'll really know whether it was triggered, or there was some other error in your microflow.